<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Mike McFeely" />
<meta property="news_keywords" content="sports,ndsu, Bison, Football, Bison football, fcs, Missouri Valley Football Conference, Northern Iowa Panthers, Mike McFeely, Sports, columnists, opinion" />
<meta property="description" content="FARGO — If somebody in Cedar Falls, Iowa, wants to scare the stuffing out Eli Dunne on Halloween, they&#039;ll dress in a green and yellow football jersey with..." />
<meta property="keywords" content="sports,ndsu, Bison, Football, Bison football, fcs, Missouri Valley Football Conference, Northern Iowa Panthers, Mike McFeely, Sports, columnists, opinion" />
<meta property="article:publisher" content="https://www.facebook.com/pages/The-Daily-Republic/114638563842" />
<meta property="article:tag" content="sports,ndsu, Bison, Football, Bison football, fcs, Missouri Valley Football Conference, Northern Iowa Panthers, Mike McFeely, Sports, columnists, opinion" />
<meta property="article:published_time" content="2017-10-28T21:14:44-05:00" />
<meta property="article:modified_time" content="2017-10-28T21:14:44-05:00" />
<meta property="image:alt" content="North Dakota State&#039;s Marquise Bridges brings down Northern Iowa running back Marcus Weymiller Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="McFeely: Bison defense a nightmare for Northern Iowa" />
<meta property="twitter:image" content="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_430/public/fieldimages/1/1028/0bplup85pwxrahvsuxdzbe5xoxc.jpg?itok=AUUTz_PK" />
<meta property="twitter:url" content="http://www.mitchellrepublic.com/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa" />
<meta property="article:author" content="https://www.facebook.com/mike.mcfeely.3?fref=ts" />
<meta property="image:title" content="North Dakota State&#039;s Marquise Bridges brings down Northern Iowa running back Marcus Weymiller Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)" />
<meta property="twitter:description" content="FARGO — If somebody in Cedar Falls, Iowa, wants to scare the stuffing out Eli Dunne on Halloween, they&#039;ll dress in a green and yellow football jersey with the No. 49 on it. The Northern Iowa quarterback will be seeing it in his nightmares for awhile anyway." />
<meta property="og:url" content="http://www.mitchellrepublic.com/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa" />
<meta property="og:description" content="FARGO — If somebody in Cedar Falls, Iowa, wants to scare the stuffing out Eli Dunne on Halloween, they&#039;ll dress in a green and yellow football jersey with the No. 49 on it. The Northern Iowa quarterback will be seeing it in his nightmares for awhile anyway." />
<meta property="fb:app_id" content="1376998682553786" />
<meta property="og:image:width" content="1240" />
<meta property="og:image" content="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_1240/public/fieldimages/1/1028/0bplup85pwxrahvsuxdzbe5xoxc.jpg?itok=OKuedulE" />
<meta property="og:image:height" content="698" />
<meta property="og:title" content="McFeely: Bison defense a nightmare for Northern Iowa" />
<meta property="og:type" content="article" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><link rel="apple-touch-icon" href="http://www.mitchellrepublic.com/sites/all/themes/mitchellrepublic_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.mitchellrepublic.com/sites/all/themes/mitchellrepublic_theme/favicon.ico" type="image/x-icon" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="amphtml" href="http://www.mitchellrepublic.com/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa?amp" />
<link rel="shortlink" href="/node/4351057" />
<link rel="canonical" href="/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>McFeely: Bison defense a nightmare for Northern Iowa | The Daily Republic</title>
    <link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_dn1Z7ijuixoG-wMmyYi-2wgXq6gNxLsgC7vdi2dJMWs.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.3/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/css/article-slider.css?oyht9h" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?oyht9h" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/all/themes/mitchellrepublic_theme/css/global-no-mqs.css?oyht9h" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/all/themes/mitchellrepublic_theme/css/global.css?oyht9h" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.mitchellrepublic.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_F77Wk3ElhI0IWc9W9h5jNjw2XWOBI81sjCu16e_P21s.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-8', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.3/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?oyht9h"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?oyht9h"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

       var OX_dfp_options = {prefetch: true};
       if (jQuery(window).width() >= 728) {
         var OX_dfp_ads = [
            ['/7021/fcc.forum/mitchellrepublic', ['300x250', '120x600', '160x600', '300x600'], 'article-sidebar-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'top-leaderboard-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['728x90', '320,100', '320,50', '300,50'], 'mid-leaderboard-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'bottom-leaderboard-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['300x250', '320x100', '320x50', '300x50'], 'photo-gallery-ad'],
          ];
        } else {
          var OX_dfp_ads = [
            ['/7021/fcc.forum/mitchellrepublic', ['300x100', '320x50', '300x50'], 'first-mobile-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['320x100', '320x50', '300x50'], 'second-mobile-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['320x100', '320x50', '300x50'], 'third-mobile-ad'],
            ['/7021/fcc.forum/mitchellrepublic', ['320x100', '320x50', '300x50'], 'fourth-mobile-ad'],
          ];
        }
//--><!]]>
</script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-MitchellRepublic"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript" src="//biddr.brealtime.com/28228967-1007.js"></script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_Y1rdwRgUs4JbtR_PFE950_FKiFhHKa6FjSWv_MUBj8g.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4351057 node-type-article domain-www-mitchellrepublic-com context-sports"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <!--<li class="last">
            <a href="/register" title="Register">Register</a>
          </li>-->
        </ul>
                </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="Classifieds">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="Marketplace">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="The Daily Republic"><img src="http://www.mitchellrepublic.com/sites/all/themes/mitchellrepublic_theme/logo.png" alt="The Daily Republic" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">The Daily Republic</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/mitchellrepublic_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4350920-police-report-details-events-leading-jamestown-murder-suicide'>Police report details events leading to Jamestown murder-suicide</a></li><li><a href='/news/state/4350940-2-accidents-involving-school-children-worry-rapid-city-officials'>2 accidents involving school children worry Rapid City officials</a></li><li><a href='/news/local/4350939-south-dakota-pheasant-hunt-concert-raise-funds'>South Dakota pheasant hunt, concert raise funds</a></li><li><a href='/news/local/4350472-inmate-mental-health-constant-concern-davison-county-jail'>Inmate mental health a constant concern at the Davison County Jail</a></li><li><a href='/news/state/4350938-native-kids-most-likely-face-poverty-south-dakota'>Native kids most likely to face poverty in South Dakota</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/local" target="_self">local</a></li><li><a href="/news/state" target="_self">state</a></li><li><a href="/news/nation" target="_self">nation</a></li><li><a href="/news/politics" target="_self">politics</a></li><li><a href="/news/crime" target="_self">crime</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">business</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/business/agriculture/4346927-playing-it-ear-minnesota-couple-loving-novelty-popcorn-business'>Playing it by ear: Minnesota couple loving novelty popcorn business</a></li><li><a href='/business/4349107-chipotles-terrible-quarter-comes-litany-reasons-why'>Chipotle&#039;s terrible quarter comes with litany of reasons why</a></li><li><a href='/business/4348537-mcdonalds-rolls-out-successor-dollar-menu-price-war-rages'>McDonald&#039;s rolls out successor to Dollar Menu as price war rages</a></li><li><a href='/business/4347882-map-shows-north-dakota-south-dakota-among-7-states-not-submit-proposal-new-amazon'>Map shows North Dakota, South Dakota among 7 states to not submit proposal for new Amazon HQ</a></li><li><a href='/business/4346279-here-most-popular-fast-food-chain-minnesota-north-dakota'>Here is the most popular fast-food chain in Minnesota, North Dakota</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="https://classifieds2.forumcomm.com/fcccontent/WFCategoryClassification.aspx" target="_self">Place a Business Brief</a></li><li><a href="/business/briefs" target="_self">Business Briefs</a></li></ul></div></div></li><li class='leaf'><a href="/tags/agriculture" target="_self">agriculture</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/business/agriculture/4346927-playing-it-ear-minnesota-couple-loving-novelty-popcorn-business'>Playing it by ear: Minnesota couple loving novelty popcorn business</a></li><li><a href='/news/4350295-agweektv-crop-loss'>AgweekTV: Crop Loss</a></li><li><a href='/news/state/4350221-perdue-tours-south-dakotas-touts-improving-soil-health'>Perdue tours South Dakotas, touts improving soil health</a></li><li><a href='/news/state/4349274-south-dakota-farmers-report-damage-dicamba'>South Dakota farmers report damage by dicamba</a></li><li><a href='/news/politics/4349084-agriculture-secretary-perdue-travel-south-dakota'>Agriculture Secretary Perdue to travel to South Dakota </a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/4351132-dodgers-big-ninth-inning-ties-world-series-2-2'>Dodgers&#039; big ninth inning ties World Series 2-2</a></li><li><a href='/sports/4351124-central-nosed-out-tie-davies-wins-state-cross-country-title-tiebreaker'>Central nosed out in a tie: Davies wins state cross country title with tiebreaker</a></li><li><a href='/sports/4351058-wild-notebook-moorheads-cullen-gets-another-ring'>WILD NOTEBOOK: Moorhead&#039;s Cullen gets another ring</a></li><li><a href='/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa'>McFeely: Bison defense a nightmare for Northern Iowa</a></li><li><a href='/sports/4351053-vikings-barr-fires-back-says-rodgers-started-war-words-after-injury'>Vikings&#039; Barr fires back, says Rodgers started war of words after injury</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/prep" target="_self">prep</a></li><li><a href="/sports/college" target="_self">college</a></li><li><a href="/sports/pro" target="_self">pro</a></li><li><a href="/sports/kernels" target="_self">kernels</a></li><li><a href="/sports/tigers" target="_self">tigers</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/entertainment/4307867-award-winning-over-ocean-first-rate-read'>Award-winning ‘Over the Ocean’ is first-rate read</a></li><li><a href='/life/farm/4307865-kirk-gratitude-little-country-things'>KIRK: Gratitude for the little country things</a></li><li><a href='/life/4307707-fulton-sisters-celebrate-10-years-bow-rehairing-restoration-business'>Fulton sisters celebrate 10 years of bow rehairing, restoration business</a></li><li><a href='/life/entertainment/4306531-acts-mary-poppins-wows-audiences-vocals-dance-scenes'>ACT’s ‘Mary Poppins’ wows audiences with vocals, dance scenes</a></li><li><a href='/life/farm/4299248-saddle-making-hobby-turned-full-time-career'> Saddle making: Hobby turned full-time career</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/entertainment" target="_self">entertainment</a></li><li><a href="/life/food" target="_self">food</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4350904-gerald-gerry-bunkers'>Gerald &quot;Gerry&quot; Bunkers</a></li><li><a href='/obituaries/4351014-robert-bender'>Robert Bender</a></li><li><a href='/obituaries/4350486-walter-nelson'>Walter Nelson</a></li><li><a href='/obituaries/4350278-peterson-charles-neal'>Peterson Charles Neal</a></li><li><a href='/obituaries/4350532-lynn-raymond-vlasman'>Lynn Raymond Vlasman</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/letters/4349651-letter-respect-all-life'>LETTER: Respect all life</a></li><li><a href='/opinion/letters/4349650-letter-appreciating-your-pastor'>LETTER: Appreciating your pastor</a></li><li><a href='/opinion/letters/4350464-letter-conservatives-perspective'>LETTER: A conservative&#039;s perspective</a></li><li><a href='/opinion/columns/4350340-woster-staying-step'>WOSTER: Staying in step</a></li><li><a href='/opinion/letters/4349646-letter-providing-positive-police-interactions'>LETTER: Providing positive police interactions</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="/opinion/columns" target="_self">columns</a></li><li><a href="/opinion/letters" target="_self">letters</a></li></ul></div></div></li><li class='leaf'><a href="/outdoors" target="_self">outdoors</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/outdoors/4348843-mitchell-vfw-post-2750-hosts-als-trapshoot-fundraiser'>Mitchell VFW Post 2750 hosts ALS trapshoot fundraiser </a></li><li><a href='/outdoors/4348838-wiltz-does-cabelas-still-book-hunting-and-fishing-trips'>Wiltz: Does Cabela&#039;s still book hunting and fishing trips?</a></li><li><a href='/outdoors/hunting/4347207-pheasant-hunters-not-fazed-lower-south-dakota-bird-counts'>Pheasant hunters not fazed by lower South Dakota bird counts</a></li><li><a href='/outdoors/4345219-wiltz-fear-learned-emotion'>Wiltz: Fear is a learned emotion </a></li><li><a href='/outdoors/4341723-wiltz-know-your-shotgun-hunting-pheasants'>Wiltz: Know your shotgun before hunting pheasants </a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/outdoors/hunting" target="_self">hunting</a></li><li><a href="/outdoors/fishing" target="_self">fishing</a></li></ul></div></div></li><li class='leaf'><a href="/milestones" target="_self">milestones</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/milestones/4350620-martin-zirpel'>Martin Zirpel</a></li><li><a href='/milestones/4350619-eugene-fristad'>Eugene Fristad</a></li><li><a href='/milestones/4350618-lois-sinkie'>Lois Sinkie</a></li><li><a href='/milestones/4350617-clara-bruinsma'>Clara Bruinsma</a></li><li><a href='/milestones/4350616-eddie-munsen'>Eddie Munsen</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/milestones/anniversaries" target="_self">anniversaries</a></li><li><a href="/milestones/birthdays" target="_self">birthdays</a></li><li><a href="/milestones/engagements" target="_self">engagements</a></li><li><a href="/milestones/new-arrivals" target="_self">new arrivals</a></li><li><a href="/milestones/weddings" target="_self">weddings</a></li><li><a href="/milestones/other-celebrations" target="_self">other celebrations</a></li><li><a href="/tags/fundraisers" target="_self">fundraisers</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="sports "> <meta itemprop='dateline' content="Mitchell,South Dakota 57301"> <meta itemprop='articleBody' content="&lt;p&gt;FARGO — If somebody in Cedar Falls, Iowa, wants to scare the stuffing out Eli Dunne on Halloween, they'll dress in a green and yellow football jersey with the No. 49 on it. The Northern Iowa quarterback will be seeing it in his nightmares for awhile anyway.&lt;/p&gt;&lt;p&gt;Nick DeLuca, the North Dakota State senior linebacker who wears that jersey, made Dunne's life a horror show Saturday, Oct. 28, at the Fargodome. Blitzing time after time, DeLuca pressured Dunne and smacked him enough times that the quarterback was looking skittish—if not downright terrified—for much of the Bison's 30-14 victory.&lt;/p&gt;&lt;p&gt;And it wasn't just DeLuca, who'll get his shot to play in the National Football League when his NDSU career is finished. The Bison defense, deep and talented, showed that no matter how much their teammates on offense struggle, NDSU will never be out of a game.&lt;/p&gt;&lt;p&gt;Football is a game in which the team with the most points wins—and it is incredibly difficult to score on this defense.&lt;/p&gt;&lt;p&gt;&quot;We're playing at a really high level on defense,&quot; Bison coach Chris Klieman said. &quot;In this league, the one thing that should never get stale or never get behind is the defense. You have to play good defense to win in this league and I think we have a really good defense.&quot;&lt;/p&gt;&lt;p&gt;In other breaking news, the sun rises in the east and sets in the west.&lt;/p&gt;&lt;p&gt;It was expected the Bison defense was going to be outstanding this year with DeLuca coming back for one more year after getting a medical hardship last season and players like Tre Dempsey, Robbie Grimsley, Nate Tanguay and a bunch of others buzzing around the field like overgrown green hornets. But this good? It might be time to compare it to the 2013 NDSU defense. Or maybe the version that carried the Bison to the 2015 national title.&lt;/p&gt;&lt;p&gt;&quot;The sky's the limit with this defense,&quot; DeLuca said. &quot;As long as we keep getting better, we're going to do some great things.&quot;&lt;/p&gt;&lt;p&gt;Dunne might not define them as &quot;great.&quot; Perhaps &quot;painful.&quot; Or &quot;debilitating.&quot; UNI's quarterback turned the ball over five times—three fumbles and two interceptions, including Grimsley's pick-six that rescued an anemic Bison offense in the first half. NDSU also sacked Dunne six times. Poor Eli looked like a bug on a windshield for most of the afternoon, much like he looked last year in Cedar Falls when NDSU defensive lineman Brad Ambrosius separated Dunne's helmet from his head.&lt;/p&gt;&lt;p&gt;The way DeLuca was streaking up the middle or barrelling off the edge, often untouched, Dunne is lucky his head didn't get separated from his body.&lt;/p&gt;&lt;p&gt;&quot;I knew we could get after him and (defensive coordinator Matt) Entz really dialed up some blitzes. I didn't think they could block DeLuca, let's be honest,&quot; Klieman said. &quot;Nick made some unbelievable plays and that's why Nick has proven he's one of the best players in FCS.&quot;&lt;/p&gt;&lt;p&gt;Dunne is exactly the type of quarterback who is going to have problems against NDSU. He is not mobile, not a scrambler or runner in the mold of South Dakota State's Taryn Christion or South Dakota's Chris Streveler. He is, against the Bison anyway, a sitting duck.&lt;/p&gt;&lt;p&gt;&quot;Without the ability to run and scramble with the quarterback, we were going to blitz and tee off,&quot; Klieman said. &quot;The guys did a great job with that. We forced them into some early throws in the second half and we got some interceptions.&quot;&lt;/p&gt;&lt;p&gt;DeLuca had an extra burst on this day, looking like the player who dominated Jacksonville State in the FCS national title game a couple of years ago and so many other teams over the years. He had that half-step back that was missing since he injured a knee early this year. DeLuca said he had the knee drained this week and that gave him more range of motion and more strength in it.&lt;/p&gt;&lt;p&gt;&quot;Nick is a prideful guy,&quot; Klieman said. &quot;When he comes off the edge and pressures, there are not a lot of guys who can block him. He's so talented, so aggressive and so physical. He made some big plays when we needed a big play to be made and that's a sign of an All-American.&quot;&lt;/p&gt;&lt;p&gt;None were better than when DeLuca rocketed into the backfield on the Panthers' first possession of the second half and stripped the ball from Dunne's hand. Fellow linebacker Levi Jordheim recovered at the UNI 21, leading to a Cam Pedersen field goal. A game that was 7-7 at halftime was suddenly 17-7.&lt;/p&gt;&lt;p&gt;With the way the Bison defense was playing, it might as well have been 170-7. This defense gives NDSU's offense some wiggle room to find its way after a slow start, which it most definitely had in the first half.&lt;/p&gt;&lt;p&gt;&quot;Relax isn't the right word,&quot; quarterback Easton Stick said. &quot;You understand that it's a really good unit out there. They're flying around out there and you know those guys are going to do great things.&quot;&lt;/p&gt;&lt;p&gt;UNI, which had been running the ball up and down the field the last couple of weeks, finished with 48 rushing yards and 157 total yards. It was a nightmarish day for more than just Dunne.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="McFeely: Bison defense a nightmare for Northern Iowa"> <meta itemprop='author' content="Mike McFeely"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-10-28T21:14:44"> <meta itemprop='dateModified' content="2017-10-28T21:14:44"> <link itemprop='mainEntityOfPage' content="node/4351057"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.mitchellrepublic.com/sites/default/files/styles/square_300/public/fieldimages/1/1028/0bplup85pwxrahvsuxdzbe5xoxc.jpg?itok=CJPHU_fE"> <meta itemprop="width" content="3432"> <meta itemprop="height" content="2435"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Mike McFeely"> </div> <div itemscope itemtype='http://schema.org/Person'> <meta itemprop='affiliation' content="The Daily Republic"</span> <meta itemprop="name" content="Mike McFeely"> <meta itemprop="homeLocation" content="Mitchell"> <div itemprop='contactPoint' itemscope itemtype='http://schema.org/ContactPoint'> <meta itemprop='faxNumber' content="(605) 996-5020"> <meta itemprop='contactType' content="customer support"> <meta itemprop='url' content="http://www.mitchellrepublic.com"> <meta itemprop='telephone' content="(701) 241-5215"> <meta itemprop='email' content="mmcfeely@wday.com"> </div> <meta itemprop='url' content="http://www.mitchellrepublic.com"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="McFeely: Bison defense a nightmare for Northern Iowa "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Mitchell"> <meta itemprop='addressRegion' content="South Dakota"> <meta itemprop='streetAddress' content="120 South Lawler"> <meta itemprop='postalCode' content="57301"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>McFeely: Bison defense a nightmare for Northern Iowa</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/mike-mcfeely-0'>Mike McFeely</a></span>
  <span class='node-byline-time'> on Oct 28, 2017  at 9:14 p.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large article-slider'><button class='next'><img src='/sites/all/themes/fcc_basetheme/images/arrow-next.png'></button><button class='prev'><img src='/sites/all/themes/fcc_basetheme/images/arrow-back.png'></button><div class='individual-slide individual-slide-1' style='position: relative;'><img class='node-image large' src='http://www.mitchellrepublic.com/sites/default/files/styles/16x9_620/public/fieldimages/1/1028/0bplup85pwxrahvsuxdzbe5xoxc.jpg?itok=XG2_pILB' data-featherlight='http://www.mitchellrepublic.com/sites/default/files/styles/full_1000/public/fieldimages/1/1028/0bplup85pwxrahvsuxdzbe5xoxc.jpg?itok=LIZd7Eoy'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>North Dakota State&#039;s Marquise Bridges brings down Northern Iowa running back Marcus Weymiller Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)</span><span class='slide-number'>1 / 5</span></div><div class='individual-slide individual-slide-2' style='position: relative;'><img class='node-image large' src='http://www.mitchellrepublic.com/sites/default/files/styles/16x9_620/public/fieldimages/1/1028/0bplup85pwxrcvjquwjymvzqttg.jpg?itok=XT4AjowZ' data-featherlight='http://www.mitchellrepublic.com/sites/default/files/styles/full_1000/public/fieldimages/1/1028/0bplup85pwxrcvjquwjymvzqttg.jpg?itok=fNHgIwIW'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>North Dakota State linebacker Levi Jordheim (45) is met by teammates Aaron Steidl (63), Stanley Jones (94) and Cole Karcz (53) after sacking Northern Iowa quarterback Eli Dunne Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)</span><span class='slide-number'>2 / 5</span></div><div class='individual-slide individual-slide-3' style='position: relative;'><img class='node-image large' src='http://www.mitchellrepublic.com/sites/default/files/styles/16x9_620/public/fieldimages/1/1028/0bplup85pwxrmmvzdvbmsvrqtnc.jpg?itok=V9h7hAsW' data-featherlight='http://www.mitchellrepublic.com/sites/default/files/styles/full_1000/public/fieldimages/1/1028/0bplup85pwxrmmvzdvbmsvrqtnc.jpg?itok=tOMAu4v4'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>North Dakota State defensive back Robbie Grimsley picks off a pass for a 27-yard touchdown return against Northern Iowa Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)</span><span class='slide-number'>3 / 5</span></div><div class='individual-slide individual-slide-4' style='position: relative;'><img class='node-image large' src='http://www.mitchellrepublic.com/sites/default/files/styles/16x9_620/public/fieldimages/1/1028/0bplup85pwxrunp4nhc2vkjqqza.jpg?itok=mASRnYXM' data-featherlight='http://www.mitchellrepublic.com/sites/default/files/styles/full_1000/public/fieldimages/1/1028/0bplup85pwxrunp4nhc2vkjqqza.jpg?itok=IGTbQ08l'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>North Dakota State linebacker Nick DeLuca strips the ball away from Northern Iowa quarterback Eli Dunne Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)</span><span class='slide-number'>4 / 5</span></div><div class='individual-slide individual-slide-5' style='position: relative;'><img class='node-image large' src='http://www.mitchellrepublic.com/sites/default/files/styles/16x9_620/public/fieldimages/1/1028/0bplup85pwxrus1acm9iumd4ake.jpg?itok=sqMRIRWh' data-featherlight='http://www.mitchellrepublic.com/sites/default/files/styles/full_1000/public/fieldimages/1/1028/0bplup85pwxrus1acm9iumd4ake.jpg?itok=2LHbgPyY'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>North Dakota State&#039;s Tre Dempsey intercepts a pass intended for Northern Iowa&#039;s Isaiah Weston as teammate Marquise Bridges assists on the coverage on Saturday, Oct. 28, 2017, at the Fargodome. (David Samson / Forum News Service)</span><span class='slide-number'>5 / 5</span></div></div><div class='node-body'><p>FARGO — If somebody in Cedar Falls, Iowa, wants to scare the stuffing out Eli Dunne on Halloween, they'll dress in a green and yellow football jersey with the No. 49 on it. The Northern Iowa quarterback will be seeing it in his nightmares for awhile anyway.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_j2r7nsf5ui7lhi4tm4soz2ytzq' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>Nick DeLuca, the North Dakota State senior linebacker who wears that jersey, made Dunne's life a horror show Saturday, Oct. 28, at the Fargodome. Blitzing time after time, DeLuca pressured Dunne and smacked him enough times that the quarterback was looking skittish—if not downright terrified—for much of the Bison's 30-14 victory.</p><p>And it wasn't just DeLuca, who'll get his shot to play in the National Football League when his NDSU career is finished. The Bison defense, deep and talented, showed that no matter how much their teammates on offense struggle, NDSU will never be out of a game.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>Football is a game in which the team with the most points wins—and it is incredibly difficult to score on this defense.</p><p>"We're playing at a really high level on defense," Bison coach Chris Klieman said. "In this league, the one thing that should never get stale or never get behind is the defense. You have to play good defense to win in this league and I think we have a really good defense."</p><p>In other breaking news, the sun rises in the east and sets in the west.</p><p>It was expected the Bison defense was going to be outstanding this year with DeLuca coming back for one more year after getting a medical hardship last season and players like Tre Dempsey, Robbie Grimsley, Nate Tanguay and a bunch of others buzzing around the field like overgrown green hornets. But this good? It might be time to compare it to the 2013 NDSU defense. Or maybe the version that carried the Bison to the 2015 national title.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>"The sky's the limit with this defense," DeLuca said. "As long as we keep getting better, we're going to do some great things."</p><p>Dunne might not define them as "great." Perhaps "painful." Or "debilitating." UNI's quarterback turned the ball over five times—three fumbles and two interceptions, including Grimsley's pick-six that rescued an anemic Bison offense in the first half. NDSU also sacked Dunne six times. Poor Eli looked like a bug on a windshield for most of the afternoon, much like he looked last year in Cedar Falls when NDSU defensive lineman Brad Ambrosius separated Dunne's helmet from his head.</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>The way DeLuca was streaking up the middle or barrelling off the edge, often untouched, Dunne is lucky his head didn't get separated from his body.</p><div id='mid-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('mid-leaderboard-ad');
          });
        </script>
        </div><p>"I knew we could get after him and (defensive coordinator Matt) Entz really dialed up some blitzes. I didn't think they could block DeLuca, let's be honest," Klieman said. "Nick made some unbelievable plays and that's why Nick has proven he's one of the best players in FCS."</p><p>Dunne is exactly the type of quarterback who is going to have problems against NDSU. He is not mobile, not a scrambler or runner in the mold of South Dakota State's Taryn Christion or South Dakota's Chris Streveler. He is, against the Bison anyway, a sitting duck.</p><p>"Without the ability to run and scramble with the quarterback, we were going to blitz and tee off," Klieman said. "The guys did a great job with that. We forced them into some early throws in the second half and we got some interceptions."</p><p>DeLuca had an extra burst on this day, looking like the player who dominated Jacksonville State in the FCS national title game a couple of years ago and so many other teams over the years. He had that half-step back that was missing since he injured a knee early this year. DeLuca said he had the knee drained this week and that gave him more range of motion and more strength in it.</p><p>"Nick is a prideful guy," Klieman said. "When he comes off the edge and pressures, there are not a lot of guys who can block him. He's so talented, so aggressive and so physical. He made some big plays when we needed a big play to be made and that's a sign of an All-American."</p><p>None were better than when DeLuca rocketed into the backfield on the Panthers' first possession of the second half and stripped the ball from Dunne's hand. Fellow linebacker Levi Jordheim recovered at the UNI 21, leading to a Cam Pedersen field goal. A game that was 7-7 at halftime was suddenly 17-7.</p><p>With the way the Bison defense was playing, it might as well have been 170-7. This defense gives NDSU's offense some wiggle room to find its way after a slow start, which it most definitely had in the first half.</p><p>"Relax isn't the right word," quarterback Easton Stick said. "You understand that it's a really good unit out there. They're flying around out there and you know those guys are going to do great things."</p><p>UNI, which had been running the ball up and down the field the last couple of weeks, finished with 48 rushing yards and 157 total yards. It was a nightmarish day for more than just Dunne.</p></div><div style='clear:both;'></div><script type='text/javascript'>
							ga('send','event','Recommended','view','recommended-view');
							ga('combinedSites.send','event','Recommended','view','recommended-view');
						</script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><script type='text/javascript'>
      	ga('send', 'event', 'Recommended', 'view with image', 'recommended-view');
      	ga('combinedSites.send', 'event', 'Recommended', 'view with image', 'recommended-view');
      </script><div class='recommended node-ad-desktop nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by The Daily Republic</div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4348244"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1024/cst-11966-wild-players-locker-room.jpg?itok=-eBLMwC1" alt="Minnesota Wild forward Zach Parise is interviewed in the team locker room at Xcel Energy Center in St. Paul on Tuesday, April 25, 2017. Scott Takushi / St. Paul Pioneer Press" />Wild's Parise undergoes back surgery, back in 8 to 10 weeks</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4346239"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1019/hockey-puck.jpg?itok=tqPRLBga" alt="" />Tickets go on sale Dec. 7 for NCAA men’s hockey West Regional</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4344412"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1016/0b52dxj0kvwfrnlbfunptql9yq00.jpg?itok=sVwidoy2" alt="Minnesota Wild forward Zach Parise (11) plays against the Winnipeg Jets at Xcel Energy Center in Oct. 2016. Brace Hemmelgarn-USA TODAY Sports" title="Minnesota Wild forward Zach Parise (11) plays against the Winnipeg Jets at Xcel Energy Center in Oct. 2016. Brace Hemmelgarn-USA TODAY Sports" />Wild's Zach Parise leaves practice with another 'setback'</a></div></div><script type='text/javascript'>
					jQuery('.recommended.node-ad-desktop a').on('click', function() {
						ga('send', 'event', 'Recommended', 'click', 'recommended-click');
						ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
					});
				</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-desktop a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-desktop a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'><div class="header-recommendation-engine-block">Additional Articles Recommended by The Daily Republic</div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4348244"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1024/cst-11966-wild-players-locker-room.jpg?itok=-eBLMwC1" alt="Minnesota Wild forward Zach Parise is interviewed in the team locker room at Xcel Energy Center in St. Paul on Tuesday, April 25, 2017. Scott Takushi / St. Paul Pioneer Press" />Wild's Parise undergoes back surgery, back in 8 to 10 weeks</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4346239"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1019/hockey-puck.jpg?itok=tqPRLBga" alt="" />Tickets go on sale Dec. 7 for NCAA men’s hockey West Regional</a></div><div class="title-recommendation-engine-block"><a class="with-img" href="http://www.mitchellrepublic.com/node/4344412"><img typeof="foaf:Image" src="http://www.mitchellrepublic.com/sites/default/files/styles/16x9_315/public/fieldimages/1/1016/0b52dxj0kvwfrnlbfunptql9yq00.jpg?itok=sVwidoy2" alt="Minnesota Wild forward Zach Parise (11) plays against the Winnipeg Jets at Xcel Energy Center in Oct. 2016. Brace Hemmelgarn-USA TODAY Sports" title="Minnesota Wild forward Zach Parise (11) plays against the Winnipeg Jets at Xcel Energy Center in Oct. 2016. Brace Hemmelgarn-USA TODAY Sports" />Wild's Zach Parise leaves practice with another 'setback'</a></div></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.mitchellrepublic.com/taxonomy/term/21'>sports</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/133030'>ndsu</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/166543'>Bison</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/221044'>Football</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/18809'>Bison football</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/7909'>fcs</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/97428'>Missouri Valley Football Conference</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/99938'>Northern Iowa Panthers</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/94963'>Mike McFeely</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/220166'>Sports</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/1202'>columnists</a><a class='topic tag' href='http://www.mitchellrepublic.com/taxonomy/term/144586'>opinion</a></div><div class='node-author-block clearfix'><a class='node-author-name' href='/users/mike-mcfeely-0'>Mike McFeely</a><img class='node-author-pic' src='http://www.mitchellrepublic.com/sites/default/files/styles/vert_175/public/pictures/picture-348787-1447773535.jpg?itok=rfFzHi9x'><div class='node-author-bio'>Mike McFeely is a WDAY (970 AM) radio host and a columnist for The Forum. You can respond to Mike's columns by listening to AM-970 from 8:30-11 a.m. weekdays.
<br />
<em>Have a comment to share about a story? Letters to the editor should include author’s name, address and phone number. Generally, letters should be no longer than 250 words. All letters are subject to editing. Send to letters@forumcomm.com</em></div><div class='node-author-email'>
        <a href='/user/348787/contact'>
          <span itemprop='email'>mmcfeely@wday.com</span>
        </a>
        </div><div class='node-author-number'>(701) 241-5215</div><div class='author-social-wrapper'><div class='fb-follow' data-href='https://www.facebook.com/mike.mcfeely.3?fref=ts' data-colorscheme='light' data-layout='standard' data-show-faces='false'></div></div></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',19);
  ga('send', 'event', 'article', 'paragraphs', '19');
  ga('send', 'event', 'article', 'length', 'characters',4990);
  ga('send', 'event', 'article', 'age', 'More than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',49940);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',19);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '19');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',4990);
  ga('combinedSites.send', 'event', 'article', 'age', 'More than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',49940);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/sports/4351132-dodgers-big-ninth-inning-ties-world-series-2-2">Dodgers' big ninth inning ties World Series 2-2<span class='latest-date'>11 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/4351124-central-nosed-out-tie-davies-wins-state-cross-country-title-tiebreaker">Central nosed out in a tie: Davies wins state cross country title with tiebreaker<span class='latest-date'>11 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/4350920-police-report-details-events-leading-jamestown-murder-suicide">Police report details events leading to Jamestown murder-suicide<span class='latest-date'>12 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/4351058-wild-notebook-moorheads-cullen-gets-another-ring">WILD NOTEBOOK: Moorhead's Cullen gets another ring<span class='latest-date'>12 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/4351057-mcfeely-bison-defense-nightmare-northern-iowa">McFeely: Bison defense a nightmare for Northern Iowa<span class='latest-date'>13 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-5">
        <div class="space-eater-headline class-14px"><a href="/sports/4351053-vikings-barr-fires-back-says-rodgers-started-war-words-after-injury">Vikings' Barr fires back, says Rodgers started war of words after injury<span class='latest-date'>14 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-6">
        <div class="space-eater-headline class-14px"><a href="/news/state/4350940-2-accidents-involving-school-children-worry-rapid-city-officials">2 accidents involving school children worry Rapid City officials<span class='latest-date'>16 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-7">
        <div class="space-eater-headline class-14px"><a href="/sports/4350999-vikings-recall-nfls-first-game-london-when-we-kicked-anything-it-was-pretty-big-deal">Vikings recall NFL's first game in London: 'When we kicked anything, it was a pretty big deal.'  <span class='latest-date'>16 hours ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget odd block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='http://www.forumnewspaper.com/dailyrepublic/' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/mitchellrepublic" title="">Subscribe to the Paper</a></li><li><a href="http://digital.olivesoftware.com/Olive/ODN/mitchelldailyrepublic/Default.aspx" title="Access E-Paper">Access E-Paper</a></li>          </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="mailto:customerservice+mitchellrepublic.com@forumcomm.com" title="">Get Website Help</a></li>
      <li><a href="http://www.forumcomm.com/careers/" title="">Work With Us</a></li>
    </ul>
  </section>
</div>
<div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.twitter.com/dailyrepublic" title="Find us on Twitter"><img alt="Find us on Twitter" src="/sites/all/themes/fcc_basetheme/images/icons/twitter-social.png" /> Twitter</a></li><li><a href="https://www.facebook.com/pages/The-Daily-Republic/114638563842" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; The Daily Republic</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; The Daily Republic</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">120 South Lawler</div>
      <span class="locality">Mitchell</span>, 
      <span class="region">South Dakota</span> 
      <span class="postal-code">57301</span>
    </div>

    Call us at <div class="tel">(605) 996-5514</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div style="display: none;"><a rel="nofollow" href="http://www.fccnn.com/newspaper.php">randomness</a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=mitchellrepublic.com&tags=sports,ndsu, Bison, Football, Bison football, fcs, Missouri Valley Football Conference, Northern Iowa Panthers, Mike McFeely, Sports, columnists, opinion',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?oyht9h"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?oyht9h"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?oyht9h"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?oyht9h"></script>
<script type="text/javascript" src="http://www.mitchellrepublic.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>
